Draxen add action=masquerade chain=srcnat
Questa riga non specifica alcuna interfaccia.
Draxen add action=mark-connection chain=prerouting connection-mark=no-mark connection-state=new in-interface="ether17 - Starlink" new-connection-mark=ISP1_Conn passthrough=yes
add action=mark-connection chain=prerouting connection-mark=no-mark connection-state=new in-interface="ether18 - Intred" new-connection-mark=ISP2_Conn passthrough=yes
in queste regole non c'è il per-connection-classifier, inoltre sono ripetute più sotto.
Non vedo il routing in questa conf.
Una conf di esempio la farei così:
Imposta i nomi delle interfacce WAN
/interface list
add name=WAN
/interface list member
add interface=ether17 list=WAN
add interface=ether18 list=WAN
Imposta gli IP statici o DHCP sulle WAN
/ip address
add address=192.168.1.2/24 interface=ether17
add address=192.168.2.2/24 interface=ether18
/ip dhcp-client
add interface=ether17 use-peer-dns=no use-peer-ntp=no disabled=no
add interface=ether18 use-peer-dns=no use-peer-ntp=no disabled=no
Imposta i gateway sulle WAN
/ip route
add dst-address=0.0.0.0/0 gateway=192.168.1.1 routing-mark=WAN1 check-gateway=ping
add dst-address=0.0.0.0/0 gateway=192.168.2.1 routing-mark=WAN2 check-gateway=ping
Aggiungi regole di NAT per la navigazione Internet
/ip firewall nat
add chain=srcnat out-interface=ether17 action=masquerade
add chain=srcnat out-interface=ether18 action=masquerade
Configura il bilanciamento del carico con PCC
/ip firewall mangle
add chain=prerouting in-interface=bridge action=mark-connection new-connection-mark=WAN1_conn passthrough=yes per-connection-classifier=both-addresses-and-ports:2/0
add chain=prerouting in-interface=bridge action=mark-connection new-connection-mark=WAN2_conn passthrough=yes per-connection-classifier=both-addresses-and-ports:2/1
Instrada il traffico in base al bilanciamento
add chain=prerouting connection-mark=WAN1_conn action=mark-routing new-routing-mark=WAN1 passthrough=no
add chain=prerouting connection-mark=WAN2_conn action=mark-routing new-routing-mark=WAN2 passthrough=no
Aggiungi regole per il failover
/ip route
add dst-address=0.0.0.0/0 gateway=192.168.1.1 distance=1 routing-mark=WAN1
add dst-address=0.0.0.0/0 gateway=192.168.2.1 distance=1 routing-mark=WAN2
add dst-address=0.0.0.0/0 gateway=192.168.1.1 distance=1 check-gateway=ping
add dst-address=0.0.0.0/0 gateway=192.168.2.1 distance=2 check-gateway=ping
Permetti traffico LAN verso Internet
/ip firewall filter
add chain=forward action=accept connection-state=established,related
add chain=forward action=drop connection-state=invalid
add chain=forward action=accept in-interface=bridge out-interface-list=WAN